Старая графикаОтчетец об экспериментах...

Обсуждение старого семейства S3Graphics: от S3 Trio до Savage 2000.
Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 06.12.2001 16:42

DF чуть позже. Я из%;№№"ся капитально, нужно отдохнуть. 3dmark2001 было 611, стало 910 ! Но есть крупные артефакты



DF
Постоялец
Сообщения: 785
Зарегистрирован: 17.07.2000 1:01
Откуда: Россия, Москва/Зеленоград
Контактная информация:

Сообщение DF » 06.12.2001 17:00

Doctor:
Ок, бум ждать.

anod*

Сообщение anod* » 06.12.2001 17:05

Так GeForce не тормозил. В мненю выбора машин у них вместо колес дырки, а сама игра - вообще полная радуга, всё смывается....

Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 06.12.2001 19:47

В общем дела пока не очень, в основном благодаря мне самому. Но всё еще только начинается.
Начал я с того, что катанул с S3graphics дрова для S3 twister 4.13.01.3014 for w9x.
По своей дурости, забыл записать ключи которые были у меня установлены для s4. Заменив 3d S4 на 3d S3 twiker , перезагрузился. Комп на удивление загрузился, но небыло букв (однако!). Перейдя в 256 цветов, я получил рабочий режим с буквами и со всем остальным. Все меню настройки карты работают. Далее (2 глупость моя), я в S3tweak взял и убрал все ключи (соотв. он подчистил еще сам реестр). После этого запустил B&W – пошло отлично во всех режимах без артефактов. Затем запустил Thief II, тоже всё отлично. Затем запустил 3dmark2001 – всё замечательно, только отсутствует освещение на текстурах. Выложу картинки – поймете. Но тест прошел на УРА (то что он вообще пошел!). Пробовал на 500 целе. И на этом месте я решил еще раз перезагрузится. После этого, я поставил драйвера в наглую и началось. На моём butterfly есть глюк с DMA. Убирается командой DMACB=”4A” или DMACB=”4P”. Глюк заключается в том, что через некоторое время машина виснет намертво, если нет вышеуказанной команды. С установленными драйверами, началось тоже самое, но введение данной команды увы не помогло. Сейчас запускается только 3dmark 2001, но через некоторое время виснет, причем намертво. Я перепробовал за 6 часов, комбинаций 50. Безрезультатно. Вероятно, надо чистить реестр или ставить систему с 0. У меня глючная карта, но у остальных должно быть нормальные. Попробуйте – будет зависать или нет.
Немного сумбурно, но просто я задолбался. Это еще первые шаги и я не знаю, стоит ли этим заниматься. Однако сам факт, уже приятен. OpenGL к сожалению не запускается нормально. Экран как-бы двоится, нет нормального наложения текстур. Но с этим я не занимался.
Сегодня пробный день, если кому будет интересно, вероятно общими усилиями что-то можно сделать.
Драйвера для Twister поддерживают DX8, а для Savage 8.20.38 – DX7.
В общем пока так, буду терзать дальше. Меня честно прибило.
А выводы такие : при определенных настройках всё работало точно. Есть проблемы DX8, но может быть это исправимо.

ЗЗЫ:Переставил систему – начал заново мучаться. Присоединяйтесь Изображение.

anod
Постоялец
Сообщения: 130
Зарегистрирован: 09.01.2001 1:01
Откуда: Israel
Контактная информация:

Сообщение anod » 06.12.2001 20:20

2 Doctor,
Я с драйверами не разбирался.
Можно ли пояснить какой файл, для чего,
ну или основные?
я знаю только metal.dll (как догадался?)

EGA
Постоялец
Сообщения: 135
Зарегистрирован: 18.11.2001 1:01
Откуда: Калуга
Контактная информация:

Сообщение EGA » 06.12.2001 21:16

Ура, господа! Рад, доктор, что я на что-то вас сподвигнул! Слишком поздно прихожу домой - нет времени , хотя здесь стоят S4-8Mb-PCI и S2k 64 Mb. Пока выяснил, что в выключенном состоянии параметр COB часто приводит к зависаниям. Лучше удалить его воообще.

Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 06.12.2001 23:04

Все попытки пока без результатов Изображение. Может мой аксель действительно глючный. Тогда вся надежда на вас.
Итак файлы.
3D:
S3_8M.DLL – этот переименовывается в S3_8.DLL
S3_8M.DRV – этот переименовывается в S3_8.DRV
S3VDD8M.VXD - – этот переименовывается в S3VDD8.VXD
И исходные и переименованные копируются в папку Windows\System (под DOS конечно).
Далее туда копируются:
S3VID.DLL
S3HAV.DLL
OPENGL:
NBICD.DLL – переименовывается в s3micd.dll
Если хотите совсем в кайф, просто установить драйвер целиком. Появится режим Overlay, S3gamma (очень красиво смотрится). На саважных дровах такого не сделали Изображение.
EGA
У меня хорошо работала такая связка
COB=”ON”
PD=”ON”
ST=”ON”
-------------------
Всё для w98\w95 конечно

<small>[Это сообщение изменил Doctor (изменение от 06-12-2001 23:07).]</small>

EGA
Постоялец
Сообщения: 135
Зарегистрирован: 18.11.2001 1:01
Откуда: Калуга
Контактная информация:

Сообщение EGA » 06.12.2001 23:22

Спасибо, док. Сейчас пробую голую систему + драйевра. Плюс 1 настройка твика. Каждый раз новая.
А по-поводу Video-bios, похоже он зашит в чипсет и не меняется. Я облазил штук 10 сайтов, скачал все биосы - дохляк. На Via и S3 - тоже пусто, уроды.

Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 07.12.2001 2:19

Надо людей с ProSavage попросить сделать dump если это возможно. Я серьезно не знаю, расковырял пару биосов до ниточки - быстрый взгляд ничего не дал Изображение. А видюха виснет, однако один раз, днем всё прошло на ура, кроме 2001 марка.

Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 07.12.2001 2:43

http://hsf.fromru.com/nd.rar
А вот и картиночки (200к архив\rar2.9) 3dmark2001 просто ужасен Изображение. Но это только там, где освещение. В остальном, графика мне показалась более четче. С рефернс не сравнивал

<small>[Это сообщение изменил Doctor (изменение от 07-12-2001 02:45).]</small>

pmv
Новичок
Сообщения: 38
Зарегистрирован: 11.01.2001 1:01
Откуда: Новосибирск
Контактная информация:

Сообщение pmv » 08.12.2001 1:16

Doctor
Надеюсь, Вы не забыли переименовать 3DMARK2001.exe в 3DMARK2000.exe?
Кстати, в Download выложен S3tweak v1.16i, работает в W2K/XP, не пробовали?

Doctor
Постоялец
Сообщения: 390
Зарегистрирован: 18.12.2000 1:01
Контактная информация:

Сообщение Doctor » 08.12.2001 2:36

pmv
Драйверы 4.13.01.3014 адаптированы под 3dmark2001 и уже ничего переименовывать не надо, в отличии от S4 8.20.38 Изображение. Под w2k\wXp не работает драйвер.
s3tweak не пробовал, но s3tweaker работает прекрасно.
PS Сегодня всё теже зависоны. Неужели никто не попробовал?

<small>[Это сообщение изменил Doctor (изменение от 08-12-2001 02:40).]</small>

anod
Постоялец
Сообщения: 130
Зарегистрирован: 09.01.2001 1:01
Откуда: Israel
Контактная информация:

Сообщение anod » 08.12.2001 11:40

2 pmv
В 2000 s3Tweak у меня 1 раз запустился и всё.
2 Doctor.
1ю часть, с переименовыванием и так далее, я пробовал. Таже фишка - 256 color, и ничего особо не сделаешь. Потом поставил всё обратно, но оставил s3micd.dll и в counter-strike играл.
В direct3d прада, а OpenGl просто подвисал.
А драйвер я не понял как устанавливать. Setup.exe, ясное дело не работает, а inf файл тоже какю-то фигнгю выдает.

anod
Постоялец
Сообщения: 130
Зарегистрирован: 09.01.2001 1:01
Откуда: Israel
Контактная информация:

Сообщение anod » 08.12.2001 11:43

Сейчас XP беде ставить.

anod*

Сообщение anod* » 08.12.2001 13:44

Вот я и в ХР.
Самое приятное, что комп уже завис 1 раз, при просмотре OpenGl заставки, так што драйвер я поменя на 03. Интересно теперь насчёт конфликта с ACPI. Полазю, посмотрю.

Ответить

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость